SharePointCommunity
Die deutschsprachige Community für SharePoint, Office 365 und mit Azure

Element in anderer Liste erstellen

bewertet von 0 Usern
Beantwortet Dieser Beitrag hat 1 Geprüfte Antwort | 5 Antworten | 1 Follower

Top-75-Beitragsschreiber
159 Beiträge
Herje70 erstellt in 28 Nov 2018 14:22

Hallo Zusammen,

aus einer Quellliste lasse ich einige Elemente in einer Zielliste per Nintexworkflow erstellen. nun soll noch eine Auswahl der Quellliste (JA, NEIN) übernommen werden. in der Zielleiste gibt es das gleiche Feld (Auswahl, JA, NEIN).

Problem:

egal was und wie ich es bisher anstelle, es erscheint in der Zielliste immer nur false.

was mach ich denn da falsch? Oder kann ich eine Auswahl nicht "kopieren"?

 

vg Jens

Beantwortet Geprüfte Antwort

Top-75-Beitragsschreiber
159 Beiträge

Ich nehme dem Umweg über einer Variablen und Lasse diese als NUR-TEXT ausgeben. Somit funktioniert das Ganze wieder.

VG Jens

Alle Antworten

Top-10-Beitragsschreiber
18.855 Beiträge

Das ist offenbar kein Auswahlfeld, sondern ein Ja/Nein-Feld.

Viele Grüße
Andi
af @ evocom de
Blog
Top-75-Beitragsschreiber
159 Beiträge

Hallo Andi,

danke für deine Antwort. Es sind in allen Listen die Gleichen Auswahlfelder enthalten, in Quell- und Zielliste. Mit einem JA/NEIN Feld hatte ich es ursprünglich versucht, da aber auch damit nur ein false übertragen wurde, bin ich gesamthaft auf Auswahl gegangen. Damit andere Kollegen, die auf der Zielliste nur Leserecht haben, auch in der Zielliste Punkte pflegen können, habe ich noch eine Liste angelegt wo die ID des Elementes der Zielliste und die Auswahl eingetragen werden können und per Idenditätswechselschritt in die Zielliste geschrieben werden. Da funktioniert es, JA oder NEIN wird eingetragen. Nur aus der anderen Website heraus nicht.

VG

Top-10-Beitragsschreiber
18.855 Beiträge

Sorry, aber da ist etwas durcheinander. Ein Auswahlfeld zeigt prinzipiell jeden Text an, den man dort reinschreibt. Über den Browser geht das nur mit den vorgegebenen Auswahlen (hier also Ja und Nein). Per Programmcode bzw. per Workflow kann man aber auch beliebigen Text reinschreiben und in Deinem Fall ist das offenbar "false". Woher das kommt, mußt Du aber selbst rausfinden.

Viele Grüße
Andi
af @ evocom de
Blog
Top-75-Beitragsschreiber
159 Beiträge

Guten Morgen,

da haben wir aneinander vorbei geredet, in der Quellliste ist u.a. ein Auswahlfeld vorhanden, gefüllt mit JA und NEIN, Standardwert ist NEIN. In der Zielliste (auf einer anderen Website) ist auch eine Auswahl vorhanden, gefüllt mit JA und NEIN, Standardwert ist NEIN. Beide Felder sind also gleich.

Der Workflow erstellt in der Zielliste ein neues Element und überträgt einige Felder in das neue Element. Nur dieses zusätzliche Feld wird mit false übertragen, egal ob in der Quellliste JA oder NEIN gewählt wurde.

 

VG

 

Top-75-Beitragsschreiber
159 Beiträge

Ich nehme dem Umweg über einer Variablen und Lasse diese als NUR-TEXT ausgeben. Somit funktioniert das Ganze wieder.

VG Jens

Seite 1 von 1 (6 Elemente) | RSS