SharePointCommunity
Die deutschsprachige Community für SharePoint, Office 365 und mit Azure

Metadaten ändern sich beim auschecken

bewertet von 0 Usern
Beantwortet (ungeprüft) Dieser Beitrag hat 0 Geprüfte Antworten | 4 Antworten | 3 Followers

Ohne Rang
2 Beiträge
Teco erstellt in 4 Okt 2017 11:18

Hallo zusammen,

 

ich habe ein kleines Problem beim Auschecken, folgende Situation:

Ich verwende Sharepoint als Datenverwaltungssystem ich habe Dokumente ( Word) die ich Jedes Jahre neu erstelle und zum Pool meiner bereits vorhandenen Dokumente hinzufüge. 

Ich füge zu den Dokumenten bestimmte Metadaten hinzu, die beim Einchecken als Pflichtangaben hinzugefügt werden müssen.

Beispiel:

Dokument (2016 mit Metadaten Zweck und bestimmter Sachnummer  )

Folgedokument  (2017 Basiert auf Dokument von 2016 mit neuer Sachnummer)

ich habe Das Folgedokument wie folgt hinzugefügt: Windows Browser geöffnet Datei von 2016 entnommen Daten geändert innerhalb das Dokuments und im Neuen 2017 Ordner hinzugefügt. 

Alles soweit so gut ..Datei wird mir auch in Sharepoint angezeigt, Eigenschaften wurden innerhalb der Sharepoint Website neue  bearbeitet --> Pflichtfeld Sachnummer 

Jetzt zum Problem: Wenn ich das Dokument vom Jahr 2017 auschecke, etwas bearbeite innerhalb des Dokument, dieses wieder Einchecke springt beim mir die neue Sachnummer wieder auf die alte zurück trotz dessen das ich die neue Sachnummer speicher!

kennt jemand Rat? Weiß jemand was dies verursacht? 

 

vielen Dank!

 

Alle Antworten

Ohne Rang
12 Beiträge

Hi,

Rat leider nicht, aber habe ähnliches Verhalten auch bei uns unter SharePoint 2016 festgestellt. Darf man fragen welche Office Version verwendet wird? Ich glaube, das ist ein Problem von Office 2016 pro plus, welches wir im Einsatz haben, konnte es aber noch nicht zu 100% nachstellen oder irgendwie debuggen. Auch der Termstore oder Personenfelder stehen nicht zur Verfügung.

Grüße, Michael

Ohne Rang
2 Beiträge

Hi,

Office 2013, ich gehe davon aus das sich beim hochladen etwas zerschossen hat, aber ganz mein Problem löst das nicht, eigentlich gar nicht :(

ich wüsste nicht was ich beim Hochladen der neuen Daten falsch mache, eigentlich weiß ich auch gar nicht, ob das wirklich das Problem ist.

 

Gruß

Top-25-Beitragsschreiber
Männlich
340 Beiträge

Wie sieht es aus, wenn du dir die Server-Eigenschaften im Word einblenden lässt vor und nach dem Speichern?

Könnte es ggf. mit dem Kopieren auf Explorer-Ebene zusammen hängen? Versuch mal die Datei 2016 zu öffnen, dann aus Word heraus unter neuem Pfad im SharePoint zu speichern, sodass es kein Copy&Past sondern ein wirkliches neuspeichern ist.

SharePoint Enthusiast

Ich helfe gern, wenn es mein Zeit zu lässt :)
Gern auch per direkter Anfrage auf XING

Top-150-Beitragsschreiber
Männlich
107 Beiträge

Hallo,

die Metadaten, welche in SharePoint verwendet werden in diversen Spalten, werden auch im Office-Dokument gespeichert. (Das Office Dokument, in dem Fall die Word-Datei, ist ja eine ZIP Datei. Diese Zip Datei wird um einige Einträge ergänzt, sobald man eine Datei auf SharePoint hochläd.)

Nun ist es so, dass SharePoint in die ZIP Datei die Spalten-ID mit der entsprechenden Information schreibt. Ich könnte mir vorstellen, dass darin dann die alte Information noch vorhanden ist. 

Zu einer Kuriosen Situation kann es kommen, wenn Du zwei Bibliotheken verwendest mit jeweils einer Spalte, z.B. "Vertragsnummer", dann die Datei von einer in die andere Bibliothek kopierst. - Solltest Du nun keine Websitespalten verwendet haben, sondern jeweils die Spalte in der Bibliothek angelegt haben, so hast Du massiven Stress mit den Metadaten: 

In der ZIP Datei wurde ja noch die alte Spalte reingeschrieben und zusätzlich kommt die neue dazu, sobald Du die Datei dann in die zweite Bibliothek hochlädst. Word liest aber die Werte der alten Spalte aus. SharePoint verwendet aber ja nun die "neue" Spalte - und hat somit andere Werte... 

Viele Grüße

Thomas

 

Freundliche Grüße
Thomas Maier

PTM Akademie – Leiter Collaboration

 

Seite 1 von 1 (5 Elemente) | RSS